centos6升级python版本

admin Linux 2个月前 249℃ 0
摘要:

提示python版本太旧查看python的版本python -V Python2.6.6 更新gcc,因为gcc版本太老会导致新版本python包编译不成功yum-...

QQ截图20170718223139.png

提示python版本太旧

查看python的版本

python  -V 

Python 2.6.6 

更新gcc,因为gcc版本太老会导致新版本python包编译不成功

yum -y install gcc 

安装依赖zlib、zlib-devel

yum install zlib-devel

下载python最新版本(最新版地址https://www.python.org/ftp/python/

)

wget https://www.python.org/ftp/python/3.6.2/Python-3.6.2.tgz

解压

tar -xvf Python-3.6.2.tgz

安装

#cd Python-3.6.2

#./configure 

#make all 

#make install 

#make clean 

#make distclean 

# /usr/local/bin/python3 –V 

编译安装完毕以后,可以输入上面一行命令,查看版本 

QQ截图20170718212858.png

建立软连接指向到当前系统默认python命令的bin目录,让系统使用新版本python 

#mv /usr/bin/python /usr/bin/python2.4 //当前python的版本为2.4所以是python2.4 

#ln -s /usr/local/bin/python3.3 /usr/bin/python 

输入#python -V,即可查看当前默认python版本 

默认的python成功指向3.6.2以后,yum不能正常使用,需要修改yum的配置文件 

修改yum配置文件 

#vi /usr/bin/yum 

把文件头部的#!/usr/bin/python改成#!/usr/bin/python2.4 //改为之前的老版本号 

保存退出,yum即可正常使用。如若有其他命令、软件不能正常使用,仿照yum配置文件的修改方法,修改其配置文件即可。 

至此,更新完毕。 


Tags:

发表评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。